Posts Tagged ‘gentoo’

Linksys WUSB54GC Wlan Stecker

Dienstag, Juni 29th, 2010

Dieser wird schon seit längerem vom Linuxkernel unterstützt, allerdings funktioniert sie trotz richtig konfiguriertem und kompailiertem Kernel nicht.

dmesg sagt auch warum…

Dieser Stick braucht seine firmware: Die Datei heist rt73.bin, eigentlich ist der Wlan-Chip von Ralink, also den Treiber von der Ralinkseite geladen, entpacken, Firmware-Datei rt73.bin nach /lib/firmware kopieren. Fertig.

Betriebsysteme und Kochen

Dienstag, Juni 15th, 2010

Aus dem Gentoo Forum:

Linux kann man mit dem Löffel gefüttert kriegen (von SuSE), oder selbst auf dem eigenen Herd kochen (Gentoo). Bei Windows hat man diese Wahl nicht, und der Brei schmeckt beschissen. Aber manche Leute wollen halt nicht erwachsen werden.

Wieder keine Maus und Tastatur in Gentoo

Montag, Mai 17th, 2010

X11 Driver Versionen passen nicht mehr zusammen. Lösung:

emerge -a1 $(qlist -I -C x11-driver)

PDFs mehrseitig drucken

Samstag, Dezember 12th, 2009

Eine Möglichkeit PDFs unter Linux mehrseitig auszudrucken: http://www.stefanschiffer.de/node/61

Keine Maus, keine Tastatur

Donnerstag, April 9th, 2009

Heute habe ich nicht schlecht geschaut als ich meinen PC einschaltete, und im hochgefahrenem Gentoo keine Maus und keine Tastatur hatte. Ich konnte einfach nichts eingeben. *wtf*

Zum Glück habe ich andere Systeme onboard. Gentooforum.de geschaut und herausgefunden das beim gestrigen world update der xorg server nicht mehr:

INPUT_DEVICES="keyboard mouse" (in /etc/make.conf)

sondern

INPUT_DEVICES="evdev" (in /etc/make.conf)

benötigt.

Schnell noch mit

emerge -avuDNq world

alles neu kompiliert und die eingabe ging wieder.

http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.5-upgrade-guide.xml

Weiters wird eine zusätzliche Einstellung notwendig damit Sonderzeichen funktionieren. http://www.gentooforum.de/artikel/16917/xorg-server-1-5-2-probs.html

ACPID konfigurieren (bei ASUS eee 1000h)

Mittwoch, März 18th, 2009

Ich habe mich mit den Hotkeys meines eeePCs beschäftigt. Kurz gesagt die Tastenerignisse werden durch den ACPI Dämon acpid geliefert. Die Werte werden geloggt und können so ermittelt werden.

tail -f /var/log/messages | fgrep acpid

und folgende Zeile(n)  erscheinen z.B. wenn im Kernel alles richtig konfigurert wurde und acpid korrekt funktioniert.

Mar 18 13:24:25 eee1000h acpid: received event "hotkey ATKD 00000013 00000018"
Mar 18 13:24:25 eee1000h acpid: notifying client 3838[0:1003]
Mar 18 13:24:25 eee1000h acpid: notifying client 3611[102:1001]
Mar 18 13:24:25 eee1000h acpid: executing
action "/etc/acpi/eeepc-actions.sh hotkey ATKD 00000013 00000018"
Mar 18 13:24:25 eee1000h acpid: action exited with status 0
Mar 18 13:24:25 eee1000h acpid: completed event "hotkey ATKD 00000013 00000018"

im Ordner /etc/acpi/events muss es einen File geben der die events behandelt. Zum Beispiel so:

event=hotkey ATKD
action=/etc/acpi/eeepc-actions.sh %e

wenn jetzt ein ereignis mit  hotkey ATKD reinkommt wird der Script  eeepc-actions.sh aufgreufen. Dort erfolgt die Behandlung folgenderweise:

#MUTE / UNMUTE Sound
00000013)
amixer set Master toggle;;

Mehr Informationen z.B. im Gentoo-Handbuch.

Evince Mime Type Fehler

Sonntag, März 15th, 2009

Seit einiger Zeit  bekomme ich die folgende Fehlermeldung wenn ich ein pdf-Dokument mit evince öffnen möchte:

unable to open document 

unhandled mime type

geholfen hat das löschen des mime.caches.

rm ~/.local/share/mime/mime.cache

Schreibhilfen

Montag, Oktober 13th, 2008

Zurzeit schreibe ich an einen größeren Latex-Dokument. Durch die Größe sind auch einige Rechtsschreibfehler im Dokument. Diese muss ich natürlich korrigieren.

Als Ausgang habe ich ein pdf File den ich mit der Seite http://www.koolwire.com/ in eine rtf Datei konvertiert habe. Danach lade ich die Datei mit OpenOffice, allerdings muss man die deutschen Bibliotheken nachinstallieren, da sie aus lizenrechtlichen Gründen fehlen. Mit emerge -avt app-dicts/myspell-de können diese nachinstalliert werden.

ati 3d rage pro auf gentoo

Mittwoch, August 20th, 2008

Ich habe in einem laptop eine ati 3d rage pro Karte verbaut. So bekommt man sie unter gentoo zum laufen:

in /etc/make.con:

VIDEO_CARDS="vesa mach64"

und emergen:

emerge -va xorg-server mesa x11-drm

evtl muss man in /etc/portage/package.keywords

x11-libs/libdrm
x11-base/x11-drm

freischalten um die neuesten Treiber zu bekommen.
in /etc/X11/xorg.conf sollte unter

Section "Device"

der Treiber

Driver      "mach64"

eingetragen werden.

Kernel Module Problem (nv oder nvidia)

Donnerstag, April 3rd, 2008

Ich hatte in den letzten Tagen ein komisches Problem mit meinem Kernel 2.6.24-4. Wenn ich meine X mit dem Treiber nv startete, lief alles einwandfrei. Lud ich den nvidia Treiber beim X starten, um satte 3D Beschleunigung zu haben, ging das Netzwerk nicht mehr.

Nach einem Hinweis im www.gentooforum.de schaute ich mir die dmesg Ausgaben mit nv und nvidia an. Beim Vergleichen entdeckte ich das irgendwas mit den Interrupts nicht passte, und den Hinweis ich solle beim booten irqpoll aktivieren.

Das habe ich auch getan, und das half auch. Woran es wirklich genau liegt weiß ich nicht, es scheint das im Kernel etwas nicht stimmt. Das ganze funktionierte ja mit einem älteren Kernel tadellos.

Vielleicht hilfts ja wen…

NACHTRAG:

irqpoll verlangsamt allerding meinen PC, deswegen habe ich versucht einen älteren Kernel, nämlich 2.6.23-6, zu benutzen, und siehe da, mit dem gehts auch ohne irqpoll. Warum das so ist, weiß ich nicht so genau.

Firebug für Firefox

Dienstag, März 11th, 2008

Leider funktioniert Firebug nicht ohne den USEFLAG mozdevelop in Gentoo. Bitte einmal neukompalieren.

3D Oberfläche

Mittwoch, Februar 27th, 2008

Dank compiz-fusion und einer modernen Nvidia Grafikkarte läuft bei mir auch eine schicke 3D – Oberfläche.

3d_desk_m.jpg

Stellarium startet nicht !

Montag, Februar 25th, 2008

http://www.stellarium.org/de/

-------------------------------------------------------
[ This is Stellarium 0.8.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2006 Fabien Chereau et al         ]
-------------------------------------------------------
Warning: Couldn't set 1280x1024 video mode (X11 driver not
configured with OpenGL), retrying with stencil size 0
Error: Couldn't set 1280x1024 video mode: X11 driver not
configured with OpenGL!

LÖSUNG:

emerge -avt libsdl

evtl. sollten die Grafikkarten treiber auch neu installiert werden

Gentoo + DistCC

Montag, Februar 25th, 2008

Endlich habe ich es geschafft…Viele kleine tückische Fehler verhinderten, daß portage und distCC bei mir zusammenarbeiten. Aber nun ist es soweit, mein alter ATHLON XP hilft brav mit beim compalieren.